Natsemi oversized packet lockup

If you’re having trouble with a natsemi ethernet controller locking up in Linux after complaining about oversized ethernet frames like this:

eth0: Oversized(?) Ethernet frame spanned multiple buffers, entry 0x00ba8b status 0xe0000bd5.

then this patch (or a kernel version which includes it; 2.6.16 or later should) may be useful. The patch is against 2.6.9+ versions of natsemi with NAPI support but doesn’t use the NAPI support.

Update: The original NAPI patch does not correctly handle shared interrupts. This has been fixed by this patch, a version of which will be integrated into the mainline kernel in version 2.6.21.

Leave a Reply